Forum

Forum Navigation
Forum breadcrumbs - You are here:ForumDorna: APICan't initialize API
You need to log in to create posts and topics.

Can't initialize API

Hi, I'm trying to set up the API on a Mac, keep running into issues like this.

>>>from dorna import Dorna

Traceback (most recent call last):

  File "<stdin>", line 1, in <module>

  File "dorna/__init__.py", line 6, in <module>

    from .api import Dorna

  File "dorna/api.py", line 406

SyntaxError: Non-ASCII character '\xe2' in file dorna/api.py on line 406, but no encoding declared; see http://python.org/dev/peps/pep-0263/ for details

 

There seem to be a few lines that pop up like this, including this one, line 412 ( which gives invalid syntax on print(percentage_text,square_text,_command_text,  end="\r") . )

I've downloaded the git repo labeled dorna-1.3.0, which is indicated to be the most recent. Is there some mistake I'm making that is keeping me from being able to use the API? Please advise, thanks!

Small update, I've found that you have a API version 1.4.2, which I have downloaded (may want to update your link in the Dorna API Quick Start Tutorial under Github!). However, I'm still running into issues when running the "from dorna import Dorna" command, just with a different line number (469 instead of 406). Let me know if I'm doing something incorrect!

Solved, I wasn't using Python3!